ipod touch: speaker volume quiet with hiss , new ios stuck

Home  >>  iPhone  >>  ipod touch: speaker volume quiet with hiss , new ios stuck

ipod touch: speaker volume quiet with hiss , new ios stuck

On March 27, 2015, Posted by , In iPhone, With Comments Off on ipod touch: speaker volume quiet with hiss , new ios stuck

Hi,


A little stumped on this one; 4th Gen Ipod Touch. Replaced the volume/power flex cable – this now works absolutely fine.

However in doing so had completely remove the logic board/battery.

Having put it all back together, playing music out of the external speaker is very quiet, Along with a lot of background hiss (like the sound when you turn up a stereo very loud Along without playing anything).

There is also occasional clipping/clicking on certain tracks Along with lots of high notes.

Playing through the headphones works absolutely fine and at the correct volume.

Ive checked the connection to the speaker itself from the red and blue wires and everything appears to be intact and as far as i can tell theres no grounding issue.

If anyones got any ideas i would greatly appreciate it. I have located this image which shows the board:

ImageShack

No Comment so far:

  1. qwerty305 says:

    quick update on this, rather than clicking ive noted its actually a high pitched beep that goes in time Along with the music. Have ordered a replacement speaker to test but am not convinced this is the issue.

    If anyone can point me in the direction of a way to test the external speaker ic or any connected components it would be appreciated.

    Thanks,

  2. Bo-Rens says:

    Just reball or change audio amp IC.

  3. tavenger5 says:

    Thanks for the feedback but the headphone output is working perfectly Along with no issues so and checking it its pretty well covered by metal shielding and nowhere near where ive done any soldering so i dont think i could have broken anything loose or ruined any connections.

    Have ordered a replacement speaker incase the part is defective. Will update if this works.

    Sam

  4. Jaydude says:

    Did you find a solution for that , I have the same issue

  5. Metaton says:
    Quote:
    Phonezone1 < >
    Did you find a solution for that , I have the same issue